0
$\begingroup$

I cannot show vertex color unlit - it keeps being affected by some global light. Does anyone know how to do this? I have selected "flat lighting" and "vertex" in color under the Viewport Shading Menu, but I still have a global light. I also tried turning off the light in the scene and tried both solid and rendered view.

I saw what might be a solution here; how to make viewport display diffuse maps in full color? (2.8) but i don't have this "REC709" option.

All i really want is to Vertex Paint in Unlit so that white color is always 100% white. It must be possible.

$\endgroup$
1
$\begingroup$

This should do the trick?

enter image description here

The Name field odf the Attribute node is the name of the Vertex Color layer you want to display.

(The mix is there to prevent the Emission shader from illuminating other objects)

|improve this answer|||||
$\endgroup$
  • $\begingroup$ Thank you - after testing your method, I realized that the normal principled BSDF actually was working with flat shading. The reason I didn't think it worked was because I picked color in Vertex Color mode, but that color would always be darker than the actual vertex color. You wouldn't know how to display the Vertec Color so that the picked color will be correct? And another question: I could not find the "holdout" node? $\endgroup$ – Dulcis Nov 11 '19 at 11:59
  • $\begingroup$ @Dulcis .. oops, yes .. 'Holdout' is a Cycles node. Pure black diffuse with a roughness of 1 will do. Otherwise, this is probably color management. Could you show your settings? $\endgroup$ – Robin Betts Nov 11 '19 at 12:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.