0
$\begingroup$

I am making a character and my whole rig is ready for skinning.

I have deformation and control bones. I want to create automatic weights only for deformation bones. Everytime when I have my bones selected (control bones are on a different layers) and hit ctrl + P -> with automatic weights I see that all my weight painting is messed up, because blender create vertex groups for all bones.

Ps. Control bones have deform option uncheck.

There was a similar question before but the answer in my case it didn't worked. Also when I go to the Weight Paint mode of my mesh and click Weights -> assign automatic from bones it doesn't work.deformation bonescontrol bones

$\endgroup$
  • $\begingroup$ could you please share your file or at least a part of it? blend-exchange.giantcowfilms.com $\endgroup$ – moonboots Nov 11 '19 at 11:18
  • $\begingroup$ In weight paint mode you have to enable the vertex selection tool and select the verts what you want to assign. (In most cases you can select all). $\endgroup$ – FFeller Nov 11 '19 at 17:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.