0
$\begingroup$

If I enable the new workspace filter add-ons feature, some add-ons that I have enabled in Blender preferences window do not show up in the filter panel. For example, I have the import AutoCAD DXF add-on enabled in the Blender preferences window but it doesn't show up in the workspace filter add-ons panel.

enter image description here enter image description here

The result is that it isn't available in the file import formats list. Does this feature have to be supported in each add-on or am I missing something? Are there any workarounds other than creating another workspace just for importing various file types? Thanks.

$\endgroup$
  • $\begingroup$ The issue is that in WORKSPACE_PT_addons(properties_workspace.py) the listed add-ons are checked for use_owner key in their bl_info. The import and export add-on don't have this set, which is why they get excluded when use_filter_by_owner is set to true (the checkbox next to "Filter Add-ons"). I'm not familiar with this part of the code, therefore I'm not sure why the import export add-ons don't have an owner. $\endgroup$ – Robert Gützkow Nov 9 '19 at 14:07
  • $\begingroup$ Thanks. I created a separate workspace just for imports and exports. Maybe it will get sorted out in a future release. $\endgroup$ – FredLarson Nov 10 '19 at 21:26
0
$\begingroup$

As a quick workaround, you could change the "category" in the bl_info section to one of the supported ones. Though "Import-Export" is listed as supported for filtering, it currently is not.

You should be able to filter them after changing, good for maintain addons via workspace.

enter image description here

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.