0
$\begingroup$

I'm trying to create a normal map for a mesh with multires modifier. Here are the steps I took.

First I unwrapped the mesh and created 32 bit float 4096x4096 texture.

enter image description here

Then I applied multires modifier and did some sculpting on the mesh.

enter image description here

I then baked the normal map with following settings.

enter image description here enter image description here

Here is what I got when I applied the baked texture onto the mesh:

enter image description here enter image description here

There are lines in-between faces which seem to follow the subdivision of the mesh with multires modifier. Why does this happen?

Interestingly this does not happen if I set the preview count in multires modifier to 4, aka the same count as the sculpt. However another artifact becomes apparent.

enter image description here enter image description here enter image description here

There are artifacts in the form of leaves all around the mesh. Does anybody know what causes this?

$\endgroup$
0
$\begingroup$

It looks like you try to make your mesh look smooth by adding more mesh subdivisions instead of setting its shading to smooth.

Unless you're on an insane project and you have all the power of the world to be able to spend hundreds of polygons on the slightest prop, this isn't the right way.
Adding mesh should be needed only if you need those extra polygons to form volume. The smooth appearance should be before all managed through shading.

Since normal baking calculates your faces' normal as is, if you're using flat shading, the baked normals will be flat as well, hence this weird patterns.

See this Blender 2.79 manual page to learn more about normals.

In short, to fix this:

  • In the 3D Viewport, select your mesh
  • In the tools panel (toggle it with T), click the Smooth button in the Edit panel:

enter image description here

Then your baking should be correct.

$\endgroup$
  • $\begingroup$ The mesh actually has a smooth shading. I shaded it smooth, than added the multires modifier. Unfortunately this does not seem to be the cause. $\endgroup$ – Lenny White Nov 6 '19 at 14:37
  • $\begingroup$ Do you think you could trace the steps and see if you get the same issues? $\endgroup$ – Lenny White Nov 6 '19 at 14:42
0
$\begingroup$

I figured out the issue. In texture settings under the Image Sampling tab, I had to toggle "Normal Map" and choose "Tangent" as the option.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.