0
$\begingroup$

I have been trying to bake a normal map from multires modifier. Here is my sculpt:

enter image description here

Here are the settings for the baking operator and the texture I used for baking:

enter image description here

Here is the normal map I got:

enter image description here enter image description here enter image description here

enter image description here

If you look closely at the last image where I applied the normal map, there are artifacts in form of small islands on the mesh. And they are all over the mesh.

What could this be caused by?

Edit:

Another artifact along the seams:

enter image description here

$\endgroup$
3
$\begingroup$

It's because of the bit depth you're using in your file. For short, you're using a 8bit depth picture, which is limited to 256 levels of shade for each red, green and blue channel. It's enough data for display on internet, but it's quickly limited in CGI.

When you create a picture in blender to bake your normal map in, make sure to check the "32 bit Float".

enter image description here

Then when you save your picture, you need also to use a format that supports all this data. You can check this in detail in this Blender manual page, but just keep in mind that usually internet-friendly picture formats like jpeg or png don't support that and the best option in Blender will be Open EXR with full color depth.

enter image description here

Then, you can use this as-is. It's heavier though, so if storage usage is a concern, there's a little trick you can do: convert that 32bit into a 8bit dithered. Basically, you would still be in 8bit with not enough data to make correct normals, but the dithering of values will make it less perceptible. If used well, it might not even be noticed.

More detailed infos and how-to's in this CG Cookie video:
https://www.youtube.com/watch?v=6D5tBEjS-N0

$\endgroup$
  • $\begingroup$ Thanks very much, this fixed it! I have another small issue, the sculpted text kind of gets cut through where the seams of the object are. I added an image to the post. Do you know if it's possible to fix this? $\endgroup$ – Lenny White Nov 6 '19 at 1:31
  • $\begingroup$ Make sure you set your mesh to smooth shading. Besides, you're using an old version of Blender with its old render engine which has been removed since the versions 2.80 and is quite different from what we use now. So unless you really need to work with this, I would recommend updating your install first so you catch up with everyone here. $\endgroup$ – L0Lock Nov 6 '19 at 13:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.