1
$\begingroup$

How do? One answer says to set Shadow Mode to none in the settings of the material, but this doesn't work in this case for some reason. The light is spot.

Shadow appears

$\endgroup$
1
$\begingroup$

FOR EEVEE:

make a material for the object and go to material properties > setting > shadow mode > none

Edit: Use contact shadows for small distances. if you want good shadows make the clips start of the light smaller and shadow resolution higher! contact shadows are only for very small details that resolution of shadow map can't cover.

enter image description here

| improve this answer | |
$\endgroup$
  • $\begingroup$ Is that different than what's in the screenshot in my question? $\endgroup$ – TimSim Nov 5 '19 at 8:54
  • $\begingroup$ Sorry didn't notice, yeah then you use contact shadows wrongly. it's only for small distances. $\endgroup$ – Mobin Nov 5 '19 at 10:06
  • $\begingroup$ Edited the answer. Also someone should report this as a bug! $\endgroup$ – Mobin Nov 5 '19 at 10:16
0
$\begingroup$

You could Use a light path node in the material and connect the is shadow to a mix between your material and a transparent shader

You can disable shadows for that light.

You might be able to disable shadows in the object settings or material settings as well.

| improve this answer | |
$\endgroup$
-2
$\begingroup$

Try adding emmesion to the yellow wall behind the object. The shadow won't appear on the wall, but the wall will glow. Just a warning if you don't want that.

| improve this answer | |
$\endgroup$
  • 1
    $\begingroup$ That may prevent the shadow from being visible, but it's not the answer to my question. $\endgroup$ – TimSim Nov 3 '19 at 20:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.