0
$\begingroup$

I tried to run a Blender 2.80 addon script on blender 2.79. But it is not working. Is there any way to run it?

$\endgroup$
  • $\begingroup$ Blender 2.80 has brought many changes to the python API, so many commands or functions of Blender 2.79 will not work on Blender 2.80. To make a 2.79 addon work on 2.80 it needs to be modified to reflect those changes by the creator or by any other people of the community who is willing to spend the time on it. I suggest you to search for the update version on the internet, and if it's not there, ask on this or other forums for the updated version. Many other people will probably benefit from it as well $\endgroup$ – Tareyes Nov 3 '19 at 11:14
1
$\begingroup$

No there isn't. The Python API has changed between the two versions and therefore add-ons for Blender 2.79 won't run in Blender 2.80 and the other way around.

You would have to modify the code of the add-on to let it run in Blender 2.79.

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.