3
$\begingroup$

I am having problem with a cycles render. My cloth simulation for a flag bakes just fine and seems to work. When I render the image gets fractured (it looks like broken glass instead of cloth). See attached images.

Someone said to post the blender file. I can't figure out how to do that.
OK, here is the link to the file: http://www.pasteall.org/blend/31495

I can't figure out which setting to change in the render settings to get rid of the "z fighting"

this is the first rendered image

this is the second and all subsequent images are broken in this fashion

$\endgroup$
  • 3
    $\begingroup$ Post your .blend file. And that looks like z-fighting. $\endgroup$ – someonewithpc Sep 9 '14 at 18:07
  • $\begingroup$ I think you might be using the wrong simulation... double check all your settings. $\endgroup$ – GiantCowFilms Sep 9 '14 at 18:14
  • $\begingroup$ Do you have a modifier which different settings in the render than what you baked with? To me it looks like an invalid cloth cache (causing Z-fighting). $\endgroup$ – gandalf3 Sep 9 '14 at 18:44
  • $\begingroup$ Upload it to a hosting service like pasteall, then put the link here $\endgroup$ – gandalf3 Sep 9 '14 at 23:10
  • $\begingroup$ OK, uploaded: pasteall.org/blend/31495 $\endgroup$ – Joe Sep 9 '14 at 23:24
4
$\begingroup$

This is because the cloth simulation is baked using the viewport settings of the modifier(s) above it.
As the subserf modifier above it has a viewport subdivision level of 1, but a render subdivision level of 2, the vertex locations stored in the cache are nonsensical when rendering.

To fix this, just set the render subserf value to 1:

enter image description here

If you still want to use two subserf levels, you have two options:

  • Re-bake, with the viewport subdivisions set to 2

  • Add another subserf modifier below the cloth modifier. These subdivisions won't be taken into account with the simulation, but they will smooth the result out a little bit (though a smooth modifier could probably get you comparable results with a lot less vertices), and you won't have to rebake.

    enter image description here

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.