0
$\begingroup$

This problem seems fairly simple, but I'm a noob to Blender and I have no idea how to fix it. Basically, I have this model which displays this in the bottom-right of Blender 2.8:

Verts Edges Faces Tris etc display in Blender 18510 tris

However, when I export the model to FBX, and try to use the model in Unity, it seems that the number of polygons has absolutely exploded, as it's over 30 times what appeared in Blender. This is what is displayed in the VRChat SDK:

Unity VRChat SDK polygons display 599008 polygons

So, what's going on? What's causing the amount of polygons in Unity to be vastly higher than the amount of tris in Blender? Is there some kind of automated smoothing when exporting, if so how can I stop it? The model's fidelity when displayed in Blender with 18,510 tris is plenty good enough.

$\endgroup$
  • $\begingroup$ Just remove the solidify and subdivision surface modifiers. You can find them in the properties panel (right side of the screen). $\endgroup$ – FFeller Nov 2 '19 at 7:52
  • $\begingroup$ Is it "Subdivisions" -> "Render" and "Viewport" and "Quality"? What should I set them to, one? Or do I click the X? $\endgroup$ – Aaron Franke Nov 4 '19 at 2:39
  • $\begingroup$ Viewport will be exported. Set it to 0 or click on the X. Or you can disable the modifier export in the fbx exporter under the geometry tab. $\endgroup$ – FFeller Nov 4 '19 at 7:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.