0
$\begingroup$

I have a colored plane (4 faces 4 colors) and I'd like another plane which is above the first one to change the color accordinly depending upon which face is under.Color doesn't change

I tried Data Transfer modifier but nothing happens. What's wrong? Or is there another way to do that? No Cycles render. EEVEE (2.8) or internal (earlier versions). Thank you.

$\endgroup$
6
  • $\begingroup$ You don't see results of modifier, because you are in solid mode. Try vertex paint mode. $\endgroup$
    – Serge L
    Oct 31, 2019 at 19:00
  • $\begingroup$ Serge, it doesn't help. I don't know how to attach the picture into comment, but i switched to Vertex Paint mode, render view, just render the file - it's exactly as you see on the first picture. Thank you. $\endgroup$
    – Vlad
    Oct 31, 2019 at 19:11
  • $\begingroup$ Can you share a file? $\endgroup$
    – Serge L
    Oct 31, 2019 at 19:32
  • $\begingroup$ Serge, sorry, I'm new here. What is the way to send a file? Sorry... $\endgroup$
    – Vlad
    Oct 31, 2019 at 19:41
  • $\begingroup$ Upload it here: blend-exchange.giantcowfilms.com $\endgroup$
    – Serge L
    Oct 31, 2019 at 19:44

1 Answer 1

1
$\begingroup$

Your source object doesn't have vertex colors at all, hence the problem (no data to transfer)

To add vertex colors to an object:

  1. Add new vertex color layer
  2. Go to Vertex Paint mode
  3. Enable face selecting
  4. Select face on a mesh
  5. Choose a color
  6. To fill a face with color: Paint -> Set Vertex Color

Steps above in one pic:

enter image description here

Now it is working in Vertex paint mode:

enter image description here

To see it in actual Blender Internal render, check Vertex Color Paint option in material settings:

enter image description here

And for Eevee/Cycles use Attribute node, just type vertex color layer name you have:

enter image description here

$\endgroup$
2
  • $\begingroup$ Serge, I made it and I have it work only in Texture ViewPort shading. It's grey in other modes and render as well. Is it the way it should work or something is wrong again? $\endgroup$
    – Vlad
    Oct 31, 2019 at 20:53
  • $\begingroup$ So now when I checked the box in materials it WORKS! Thanks a lot! $\endgroup$
    – Vlad
    Oct 31, 2019 at 21:07

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .