0
$\begingroup$

So I have this character animation with a shape key that flattens and unflattens his hat:

enter image description here

(in glorious technicolor here)

It looks good. But the shape key is mucking up all my other Actions now. It is an omnipresent key. I heard that this can be fixed by keying a shape key driver instead of the shape key directly. So I set out to do this. Unfortunately, I hit a nasty bug where my driver says "Mute" as soon as it is created, and I don't know how to get around that. It is possible that I am not using the correct settings, but I was following the official documentation as closely as possible. When I try to set local rotation as the determining factor, I cannot get any result at all. When I try to do local translation as the determining factor, the shape key is "mute"ed from the moment his hat is scrunched (that is, it becomes instantly un-scrunched) to the moment his hat pops back up again (another pop-in transition); The shape key is being muted and it is preventing me from having any idea what I should be doing. Can anyone help me?

I made a painful recording of my struggle here.

IMPORTANT NOTE: This character is going to be exported into Unity so I can't use modifiers that will not export to FBX.

$\endgroup$
  • $\begingroup$ Perhaps use hooks to flatten the hat instead? You can parent the hooks to the main bone or character but it might be a lot safer to instead, add an Empty with which to animate the armature or character's rotation to the inverted pose. Parent the armature to that, then parent the hooks to that also. Hooks can then be keyframed 'locally' and shouldn't interfere with anything else. $\endgroup$ – Edgel3D Nov 1 at 5:05
  • $\begingroup$ @Edgel3D I am checking Google and I am only getting results for a "Hook Modifier", is this what you mean? Because I need to export this character to Unity and the modifiers will disappear on conversion to FBX. As far as the inversion goes, that is a good idea but I don't want to redo the whole animation. I have been advised to have 2 versions of the character in Unity that I can swap in and out just for this animation, and that seems viable. The sticking point is the hat's shape keys. Is there another way to key this effect that will export correctly? $\endgroup$ – hatinacat2000 Nov 1 at 6:32
  • $\begingroup$ It's a canned-animation and I know all the required offsets. I can get his transform from Unity to make it perfect. I am just having problems with the hat scrunching in all my 20 other animations $\endgroup$ – hatinacat2000 Nov 1 at 8:40
  • $\begingroup$ The one thing you could do is to rotoscope in 3D. i.e. apply the shapekeys for each frame the hat is to go from scrunched back to normal. You end up with 3 or 5 multiple hats, depending on the speed you're after. All hats will be there, following the character's head, but only one is visible at any one frame. A little like a movie film showing one frame at a time and in sequence. Each hat will be deformed in varying degrees as hard mesh so an external game engine should accept them ok. $\endgroup$ – Edgel3D Nov 2 at 5:10
  • $\begingroup$ The character mesh is entirely one object. The first scrunching part is 8 frames and the un-scrunching is 5 frames. So I would need 13 additional meshes for a situational character prefab. I would like to be able to scrunch and un-scrunch his hat in multiple animations, as the game requires. The driver bones seem like they should be exactly what I need, and almost work, there is just some strange problem I am encountering in my "unique" situation. I am considering uploading a minimal working example to see if somebody can make it work and report the solution. $\endgroup$ – hatinacat2000 Nov 2 at 5:48
0
$\begingroup$

The problem was that I was setting a driver for the MUTE property of the shape key, not the VALUE property. In order to set a driver for the VALUE, right click the value and you will see an option to add a driver.

I was convinced yesterday that it was not possible to right-click the VALUE (as of 2.80) and see an option to add a driver, that I had to right-click the checkbox instead. This was a mistake. Thank you to everyone (@Edgel3D) who tried to help. The problem is now solved.

$\endgroup$
  • $\begingroup$ Good to hear that, and I've learned something :) $\endgroup$ – Edgel3D Nov 3 at 3:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.