1
$\begingroup$

I am trying to do this...

enter image description here

... as featured in this post, but in blender 2.8.

The only way that I can get anywhere close is to create an ocean slightly larger in X & Y than the cube, but shorter in Z. Then add a boolean on the cube with the object as the ocean and the operation set to difference. However, I can then only remove the faces of the cube above the ocean once the boolean modifier is applied, which means that the animation won't work.

What am I doing wrong?

Thanks,

Simon

EDIT: Having downloaded blender 2.79 and added a boolean intersect to the cube I get similar behaviour to blender 2.8 when the solver is set to BMesh...

enter image description here

...but setting the solver to Carve gives me the desired result.

enter image description here

So it looks as if blender 2.8 (which has removed the solver Carve) cannot generate the desired result.

So the questions stands, how do you create a slice of ocean with an animated surface in blender 2.8?

Thanks (again),

Simon

$\endgroup$
  • $\begingroup$ Don't apply modifier, just hide Cube from viewport and rendering - settings are in Outliner. $\endgroup$ – Serge L Oct 30 '19 at 18:08
  • $\begingroup$ Thanks Serge L. However, I want the sides of the cube visible to give the appearance of a slice or cross section of ocean $\endgroup$ – fractal Oct 30 '19 at 20:10
  • $\begingroup$ does it need to be the Ocean modifier? Because you could fake it with the Displacement modifier or other... $\endgroup$ – moonboots Oct 30 '19 at 20:31
2
$\begingroup$
  1. Add a Plane and subdivide it couple of times
  2. Select its border and add it to a new vertex group

    enter image description here

  3. Add all modifiers to the stack, pay attention to green highligts

    enter image description here

Ocean should be Displace instead of Generate in order to utilize vertex group.

Vertex group later is displaced strictly on Z axis down below and cut by Cube via boolean Intersect.

Adjust Cube's scale as you need and enable Autosmooth (80 deg) in Plane settings to have a sharp corner at the cut.

$\endgroup$
  • $\begingroup$ Following your instructions I cannot generate the output required. One missing element was to set the Displace modifier strength to -20, but even then I cannot replicate what you have done. I think the issue might be in selecting the border of the plane and adding it to the vector group. However, since you have provided a .blend file I can use that. Many Thanks $\endgroup$ – fractal Oct 31 '19 at 17:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.