0
$\begingroup$

I'm struggling to get both of my GPUs to be recognized by Blender at the same time. They seem to require different ICDs to function:

RX 5700 XT: opencl-amdgpu-pro-icd (--opencl=pal from the AMD proprietary driver)

RX 580: opencl-orca-amdgpu-pro-icd (--opencl=legacy from the AMD proprietary driver)

However installing from the installer results in an error building amdgpu-dkms and therefore for this particular setup, skipping amdgpu-dkms and installing the packages manually gets either one of the GPUs working inside blender, never both even if I install both ICDs.

System Information

Operating system: Linux-5.3.0-20-generic-x86_64-with-Ubuntu-19.10-eoan 64 Bits Graphics card: AMD Radeon RX 5700 XT (NAVI10, DRM 3.33.0, 5.3.0-20-generic, LLVM 9.0.0) X.Org 4.5 (Core Profile) Mesa 19.2.1

Blender Version

2.81 (sub 16), branch: master, commit date: 2019-10-28 17:50, hash: rB43a8fdb6addf

$\endgroup$
2

0

You must log in to answer this question.

Browse other questions tagged .