0
$\begingroup$

I don't know what I've done but all the sudden whenever I open blender, it starts with the preference window open too, looking like this

enter image description here

Even resetting blender to factory defaults doesn't change it. Why is this happening and how to get rid of it?

$\endgroup$
2
  • 3
    $\begingroup$ Could be that you've saved the startup file while having the user preferences open. $\endgroup$
    – Robert Gützkow
    Oct 30, 2019 at 15:30
  • 1
    $\begingroup$ Yup. Close the preference window, and File > Defaults > 'Save Startup File' $\endgroup$ Oct 30, 2019 at 16:15

1 Answer 1

0
$\begingroup$

If you didn't do like Robert and Robin suggested (you edited the startup file while it was open) maybe check your permissions. You will need read/write permissions in your config preferences files. That's the 'rw' below.

In Linux:

ls -la ~/.config/blender/3.0/config/ total 168 drwxr-xr-x 2 tom tom   4096 Jan 15 00:43 . drwxr-xr-x 3 tom tom   4096 Dec 15 12:57 ..
-rw-r--r-- 1 tom tom     69 Jan 15 00:43 bookmarks.txt
-rw-r--r-- 1 tom tom    382 Jan 15 00:43 platform_support.txt
-rw-r--r-- 1 tom tom     42 Jan 15 00:43 recent-files.txt
-rw-r--r-- 1 tom tom 149264 Dec 15 12:57 userpref.blend

I guess you could fix it maybe with chmod -Rv u+rw ~/.config/blender/3.0/config/ potentially.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.