0
$\begingroup$

I have a recurrent dependency cycle when I launch a script to run the physics engine :

Dependency cycle detected:

OB0092.001/Transform Component/TRANSFORM_FINAL() depends on

OB0092.001/Transform Component/TRANSFORM_SIMULATION_INIT() via 'Simulation -> Final Transform'

OB0092.001/PointCache Component/POINT_CACHE_RESET() via 'Point Cache -> Rigid Body'

SCScene/Transform Component/RIGIDBODY_REBUILD() via 'Rigid Body Rebuild -> Point Cache Reset'

OB0092.001/Transform Component/TRANSFORM_FINAL() via 'RigidBody Field'

Dependency cycle detected:

SCScene/Transform Component/RIGIDBODY_SIM() depends on

OB0092.001/Transform Component/TRANSFORM_SIMULATION_INIT() via 'Object Transform -> Rigidbody Sim Eval'

OB0092.001/PointCache Component/POINT_CACHE_RESET() via 'Point Cache -> Rigid Body'

SCScene/Transform Component/RIGIDBODY_REBUILD() via 'Rigid Body Rebuild -> Point Cache Reset'

OB0092.001/Transform Component/TRANSFORM_FINAL() via 'RigidBody Field'

OB0092.001/Transform Component/RIGIDBODY_TRANSFORM_COPY() via 'Rigidbody Sync -> Transform Final'

SCScene/Transform Component/RIGIDBODY_SIM() via 'Rigidbody Sim Eval -> RBO Sync'

I am currently reading through the documentation on dependency graphs and cycles but perhaps there is an easy thing to do to avoid this mistake. The simulation is going through so I am wondering if that is even a problem at all.

Here is a sample file: Blend file. All rigid bodies are turned passive but you can turn on any to active to run the simulation again and see the settings. Nothing spectacular in there, just a sample

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.