0
$\begingroup$

I've been experiencing one particular problem for over two years without a solution.

When using Blender (even just navigation in GUI), it randomly crashes. When I look to the Events Viewer, I get errors like Application Hang and Application Error, but most of the times it's the NVIDIA OpenGL Driver error. The error says that the NVIDIA OpenGL Driver has encountered an out of memory error and might behave inconsistently.

Those errors and instability of Blender is not tied to one version, it crashed all the versions I tested, from 2.78 up to the newest 2.80 release. It doesn't matter whether I have CUDA enabled in User Preferences or not. I experienced these errors (and many of other ones) with GTX 1080, which I gave back to the seller for an RMA that resulted in getting my money back. So I bought an RTX 2070 Super, but still experience the same behavior.

I tried many times to log these crashes, but with every Blender crash, the log crashes too. Therefore no evidence of these issues.

My BIOS and GPU drivers are up to date, the OS is Windows 10 Pro 1903, CPU AMD Ryzen 1600X, 16GB of 2600MHz DDR4 RAM. I don't think it's a hardware issue. I've contacted NVIDIA Support and MSi (the GPU manufacturer) many times, and even they gave up trying to solve the problems.

I would highly appreciate any help or advice, because I don't know, what to do, I use Blender daily (and it's the only program I experience these issues with) and it's the main purpose I built my current PC.

Thank you

$\endgroup$
  • $\begingroup$ Normally when I launch Blender via cmd with --debug and manage to normally close the program, the log opened as a Blender console remains opened. When Blender crashes, it crashes only the active window + --debug console (so when I have for example 3 Blender windows opened at the same time, only one of them crashes and the others remain intact until they also crash) $\endgroup$ – Pavel Grulich Oct 29 '19 at 20:57
  • $\begingroup$ If you've tried everything else, it could be a faulty memory module, which would explain some of what you are seeing. Try removing one module (I assum you have 2 x 8GB sticks) then test, if it fails swap the memory module and test again. I had a problem like this and it drove me insane, finally I bought new RAM and everything is happy again. $\endgroup$ – Moog Oct 31 '19 at 23:07
  • $\begingroup$ Finally I got the log working and the error after crash is finally captured. CPU flags: AVX2: True AVX: True SSE4.1: True SSE3: True SSE2: True BVH layout: BVH8 Split: False CUDA flags: Adaptive Compile : False OptiX flags: CUDA streams : 1 OpenCL flags: Device type: ALL Debug: False Memory limit: 0 Version 282 sub 7 date 2020-02-12 16:20 hash 77d23b0bd76f Error: EXCEPTION_ACCESS_VIOLATION Address: 0x0000000000000000 When opened with opengl32.dll, everything worked fine, though slow. $\endgroup$ – Pavel Grulich Mar 5 at 16:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.