0
$\begingroup$

On a 2019 5k iMac, Blender displays vibrant colors. But after rendering and viewing it on macOS preview, the colors are off. I tried this with a MacBook, and the colors are displayed as they were intended. As well as on a PC (and using boot camp on the *iMac).

I'm guessing this has to do with the iMac's built in display correct? Are there any solutions?

*Another thing too, after uploading a render (that has intended colors) to a site (insta) the colors look off on other devices. Mind you I'm using regular settings...

$\endgroup$
0
$\begingroup$

The good news is that you have an awesome display. The bad news is that Blender by default does not support any type of display beyond sRGB.

So before I give you the solution, it’s probably wise to wrap one’s mind around what is happening.

Your iMac uses a different set of RGB lights to emit colour. When you render something using Blender using the default configuration, it assumes your display is sRGB. That is, it doesn’t know what kind of display you have. That means that an RGB triplet sent to the display that has no compliments such as 0.0, 0.2, 0.0 will project out a different colour light on sRGB as compared to your iMac. Of course that means by extension, every single mix of lights is totally wrong. You are seeing the lights projected out though they were connected to sRGB coloured lights as opposed to your iMac’s much more saturated and different coloured lights!

The good news is that I’ve included the Display P3 colorimetry in the official Filmic Blender repository at GitHub. Change your display to it, and your rendering should appear correctly on your iMac. Just don’t save it with that display type chosen! Any issues, feel free to post.

https://github.com/sobotka/filmic-blender

The bad news is that Blender is still pretty woefully lame regarding pixels. That means that to properly encode an sRGB image, you would need to flip your display to sRGB and save the file, as well as ideally attach the sRGB ICC tag. It’s totally wrong looking at your display, but Blender is horribly broken and it is where we are at. Another option is to leave your render set to Display P3, save it, and assign the Display P3 ICC. Painful, but works!

Hope this helps...

$\endgroup$
  • $\begingroup$ Ah thank you for being very kind to not only tell me the solution but also explaining what's happening. So concise! $\endgroup$ – alphabit Nov 6 '19 at 3:26
  • $\begingroup$ Solved it! I just opened the image I saved (with the display to P3) with ColorSync utility and assigned the P3 profile and voila! I even uploaded it on other platforms to test the colors and they are all great! THANK YOU!! $\endgroup$ – alphabit Nov 6 '19 at 4:45
  • $\begingroup$ Let me know how the Filmic configuration works for you. In theory, the Display P3 display setting should work rather well. If it is properly displayed, it should not appear as saturated as the limits of your display. $\endgroup$ – troy_s Nov 6 '19 at 5:25
  • $\begingroup$ I guess it works well, even though it's such a process to make the final image how it should look like, it works. Do you have any advice about animating with said outcome? Do I have to manually assign each frame? $\endgroup$ – alphabit Nov 7 '19 at 0:31
  • $\begingroup$ Blender’s pixel management is crap. Basically, proof your work using the Display P3 display and view of your choosing, then for rendering, set it to sRGB if you are saving as a TIFF for example. The result will be sRGB. If you save as EXR, you’d have to bake the transforms out separately. TL;DR: Change the display to sRGB and save and the animation will be sRGB. macOS should detect untagged images as sRGB. You can also batch tag still frames. $\endgroup$ – troy_s Nov 7 '19 at 9:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.