I am new to blender and since i am unaware of the terminology i dont know what to search for
I have a 'quick smoke' icosphere as a rendered mpeg file.
I have another video in which a man shows his hands as if he is holding the smoke ball.
But in Video Sequence Editor when i add both the clips and add the transform effect to the smoke clip with 'alpha over' and scale it,I get a black box (background) around the smoke.
I have tried to make it transparent as given here
Can Blender render pngs with the background transparent?
How should i display only the smoke without background?
Note:I have also tried changing the opacity of both the transform and smoke strips to no avail

  • 1
    $\begingroup$ As far as I know Mpeg format does not support alpha channel information. Try rendering the smoke as a png sequence. $\endgroup$
    – user1853
    Sep 7 '14 at 16:24
  • $\begingroup$ @cegaton thank you for the quick answer.Does AVI support alpha channel transformation?Because i tried saving it as an avi raw file ,this also doesnt show the smoke properly $\endgroup$ Sep 7 '14 at 16:36
  • $\begingroup$ @cegaton thanks a lot for helping a newbie :) I'd be glad to accept your answer if you post it,since it could help newbies like me $\endgroup$ Sep 7 '14 at 18:13
  • $\begingroup$ Note that it's a bad idea to render directly to a video anyway, as you cannot pause/stop the render without corrupting the video and losing all the progress you made. $\endgroup$
    – gandalf3
    Sep 7 '14 at 19:27

Most video formats do not support alpha channels,at least not the ones built into blender. (there is one option if you are using OSX)

You have two options:

1.- Export your scene as an image sequence with in RBGA (in a format like PNG, Tiff, TGA, Jpeg2000 or OpenEXR) and then import it into the Video sequence editor to combine your shots

2.- Do the compositing directly in blender either by importing the smoke scene as a strip into the video editor or using the compositor located in the Node Editor


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.