0
$\begingroup$

I have a horse model I'm working on. So far, so good.

Now I'm trying to add eyes with an iris texture. I added two spheres, assigned a material and a texture, but the UV Map is too small and needs to be resized (my horse now has insect eyes. Every face of the sphere has its own texture.)

When I try to apply/resize my UV Map (in Edit mode), here is what I get:

No UV map

The sphere has a Material & texture, so it should work: enter image description here

So, what am I doing wrong? TIA.

$\endgroup$
1
$\begingroup$

The faces of your sphere are overlapping in the UV Editor because you must have unwrapped with the Unwrap option (first one) without any seam on your mesh. The result is that each face displays the pupil. You should mark a seam on one of your sphere longitudes (select the edge and press CtrlE > Mark Seam), then select all and unwrap again (with the first option called Unwrap). This time it will take the seam into account. You can bring some corrections like scaling up and down the UV in the UV Editor and align it to the pupil.

enter image description here

$\endgroup$
  • $\begingroup$ Thanks for the reply. How do I "mark a seam on one of your sphere longitudes"? Must I select every vertices by hand all the way around? Because simply using Ctrl-E alone does not appear to do the trick (in Edit Mode.) $\endgroup$ – Mugsy Oct 25 at 10:56
  • $\begingroup$ in 2.79, alt left click should work to select an edge loop $\endgroup$ – moonboots Oct 25 at 10:57
  • $\begingroup$ Thx. I must be missing something though. I'm still not getting a UV Map. I select the seam (alt+LMB), Mark Seam, Unwrap, Select All (as in your photo), and get the same "too many faces selected" white box (in UV Edit mode.) If I don't Select All, I get the texture, but still no UV Map. :( $\endgroup$ – Mugsy Oct 25 at 13:53
  • $\begingroup$ Once you've marked the seam, select all then unwrap with the first option selected (Unwrap). I don't know this "too many faces selected" error... $\endgroup$ – moonboots Oct 25 at 13:56
  • $\begingroup$ Ah! Unwrap AFTER selecting All! That was my mistake. The "error" I described is when you select too many faces in "UV Edit" mode, it doesn't know what to map, so you get the white box seen in my first photo. Thx. $\endgroup$ – Mugsy Oct 25 at 14:02
0
$\begingroup$

Have you tried unwrapping it with Sphere Projection? (One of the Unwrap options)

How about using a Texture Coordinate with Mapping node to manually arrange it? (Texture Coordinate (UV Data) plugged into Mapping plugged into Image Texture plugged into Shader—adjusting the Mapping parameters to fit).

John

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.