1
$\begingroup$

I'm fairly new to Blender and I'm facing some very strange issues. It's like I've added an opposite day modifier to my file.

First, my Add and Subt option seems to be inverted. So when I draw, it digs, when I inflate, it deflates… I've checked that I've selected Add as the direction for my brush but I actually have to check Subt to be in the right way. Also, one time, my draw brush seemed confused as it was alternatively adding and subtracting in one single stroke. Very weird.

I also have a symmetry issue. Still in Sculpting Mode, I've checked the X axis in Brush Symmetry > Mirror and all the other fields are unchecked and/or at 1 but the brush is going insane. enter image description hereWhat you see is a single click with an untextured draw brush (shown by the pink arrow) and its mirror-self who has a lower strength to it and is not at the desired place (shown by the blue one). And as said before, you can see direction of my brush is Subt but I made a bump anyway. I've tried to select the Y and Z axis instead but it's still not what I'm looking for. Despite this, when in Modeling Mode, I can use the mirror modifier fine without all this nonsense.

My third and final issue, I think, is the shape of my brush. As you can see on the picture above, the bump I've made with that single click with an untextured brush is stretched instead of matching the brush and being round. I've done it with Brush Options > Sculpt Plane : Area plane. When I tried Brush Options > Sculpt plane : View plane and it only solved one of my problems : the Subt direction of my brush is now the good one (as shown by the green arrow).

I'm on Blender since five straight days and I never had those issues up until today. But today, go figure, it gradually started to go nuts and that's where I'm at. The last thing I've tried before posting this was to Load Factory Settings and copy my model into the new file created. No change on any issue whatsoever.

I suppose the solution is super simple and that I've probably just enabled batshit mode by accident but I do not know how to come back from it.

Please please help. Thanks a bunch !

(and, of course, tell me if you need more informations from me on this issue)

[[EDIT : moonboots once told me

maybe you have some flipped normals? Select all and try a Shift N to recalculate outside.

I thank that person but that was not it.

enter image description here

Now, the front of the mesh in sculpting mode looks weird when displayed in solid mode and the colors in my model flicker anytime my mouse moves when displayed in look dev mode or render preview.

It’s driving me nuts.

But maybe I made a mistake using Shift N as I wasn’t sure on where to do it. What I did is :

  • exit sculpting mode to enter modeling
  • select all my stuff in edit mode
  • Shift N
  • watch the mystery thicken

In parallel, I’ve tried earlier to open a fresh new blender file and all was working just fine. So it seems that I did something to the model itself.

[EDIT : Yeah, it's clearly that because I have another object in the scene that I've not yet fused with the rest of the model and the tools and mirror stuff works perfectly on it.]

To the best of my recollection, I was doing brush texture experiments, enabling and disabling the mirror, tuning the brush, and trying to use the radial symmetry option when it started to go off the rails. If it’s any clue to the solution.

[EDIT : I've just compared the settings of the draw brush when working on my freaky object (with the Shift N still active) and when working on an object still acting normally. enter image description here The settings to the freaky object are on the right and the only difference I spot is that it lacks a Topology Rake.

Is that the thing ?

Also, I seem to not be able to share my file as it's too big by 7Mo but I'm a super newb and may not be the best at optimizing a file…]]]

Your normals are flipped. Go in Edit mode, in the Viewport Overlays panel enable the Face Orientation option, you can see that your mesh is completely red, so when you're supposed to create bumps you create craters. Select all and press ShiftN. Also maybe you should reduce the Spacing value in N panel, and disable the Symmetry?

Oh my, thanks for your time and help ! But that's still not it, though.

First, when I check the Face Orientation box, I don't see the same thing as you. enter image description here The mesh in your picture is clean red where mine is also blue. Why ?

After having selected it all, I hit Shift N, my clay became blue and, while it did solve the inverting of Add and Subt, I still have a mirror problem. enter image description here

So what do you mean when you tell me that I should disable symmetry ? Because if it's to click it off and clicking it back on, I did and nothing changed. And if it's about doing without it, I'd rather not.

As for the reducing of the Spacing value, if you are indeed talking about this guy : enter image description here it sadly did nothing for me.

The biggest question for me is How did I get myself into this mess ?? All was fine and, suddenly, my flippin' normals are flipped and it's chaos. What did I do ??

Again, thanks a lot for your time, it's much appreciated.

$\endgroup$
  • $\begingroup$ could you please share your file? blend-exchange.giantcowfilms.com $\endgroup$ – moonboots Oct 23 at 12:16
  • $\begingroup$ I can't, no, the file is too big for blend-exange. Can I upload it on Wetransfer and past the link here ? Or is there a rookie mistake I'm probably making that skyrockets the weigh of my file ? $\endgroup$ – Motte Fraîche Oct 23 at 12:56
  • $\begingroup$ yes use another site like wetransfer or pasteall.org/blend $\endgroup$ – moonboots Oct 23 at 12:58
  • $\begingroup$ Aargh, the file size limit is the same on pasteall and even lower on wetransfer. I don't get it, my file is just a character (around 550 000 faces), how is it that big or how is those the size-limit so low ? $\endgroup$ – Motte Fraîche Oct 23 at 13:16
  • $\begingroup$ try another platform $\endgroup$ – moonboots Oct 23 at 16:16
0
$\begingroup$

Your normals are flipped. Go in Edit mode, in the Viewport Overlays panel enable the Face Orientation option, you can see that your mesh is completely red, so when you're supposed to create bumps you create craters. Select all and press ShiftN.

Also maybe you should reduce the Spacing value in N panel, and disable the Symmetry?

enter image description here

$\endgroup$
  • $\begingroup$ Thanks a lot, I've edited my answer. $\endgroup$ – Motte Fraîche Oct 23 at 18:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.