I'm trying to export one of my meshes however the options which I normally would have when exporting my mesh as an FBX are missing. Primarily what I need is to export selected objects only as it's exporting the entire scene.

enter image description here


1 Answer 1


I am guessing you have a bad UI layout in file.

(They changed the export layout in 2.81. Did you open up the 2.81 beta, save the file, and return to 2.80?)

Try to close blender, Re-open it with default scene, go to File->Open, deselect "Load UI" and open your blender file. Export settings should be back now.

enter image description here

If that does not work, (Or you are also missing the Open Blender File settings), go to File->Defaults->Load Factory Settings, then File->Defaults->Save Factory Settings.

Restart blender and try to deselect "Load UI" again.

  • $\begingroup$ So it looks like using the Blender 2.81 and then going back to 2.8 is what's causing the issues. Going back to 2.81 allowed me to export everything without any issues. $\endgroup$ Commented Nov 13, 2019 at 6:03
  • $\begingroup$ Why is the export menu's UI saved to the .blend file? Why would it ever make sense to save this information? $\endgroup$ Commented Feb 6, 2020 at 0:56
  • $\begingroup$ @AaronFranke Most of UI layout in a blender project is saved in the .blend file. It can really useful to return to an old project and have the same setup. (Or different projects with different setups.) In my opinion, it could save more to .blend file. Not just the export layout, but most recent export configuration setting (obj/fbx/etc) should be included too. So I can quickly re-export a model with same settings as last time. $\endgroup$
    – Scraphead
    Commented Feb 7, 2020 at 9:48
  • $\begingroup$ This answer really saved my day, I was stuck trying to figure out why in the world the exporting options were gone... Thank you so much $\endgroup$ Commented May 2, 2020 at 9:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .