1
$\begingroup$

I am saving an animation to a video. I crop the output image using Crop node (Crop image size is enabled), but the rendered image remains the same size, and uncropped areas become transparent pixels. If using the File Output Node, it is cropped correctly but I can save only one image at a time, not a video as I wish. Do you have any suggestion to save the video that is cropped properly? Thank you in advance!

enter image description here

$\endgroup$
  • $\begingroup$ Change the actual image output size like what it puts out $\endgroup$ – Yohello 1 Oct 22 '19 at 15:57
1
$\begingroup$

Change this setting to reflect the actual image size. enter image description here

| improve this answer | |
$\endgroup$
  • $\begingroup$ Hi, thank you but let me make it clearer. From the original image (let say 771 x 578 pixels), I apply a barrel distortion, then I want to crop the distorted image to 720 x 540 pixels in order to remove the black border. If applying 720 x 540 to the render resulution as you said, I can not get the cropped image of 720 x 540 $\endgroup$ – dsl Oct 23 '19 at 11:01
  • $\begingroup$ @sang just plug it in straight to composite and change the RENDERED RESOLUTION it will crop it I've tried it works. $\endgroup$ – Yohello 1 Oct 27 '19 at 0:39
1
$\begingroup$

The final output size of the rendered image cannot be set in the compositor.

Change the resolution setting in the properties window to the desired output image size.

To make the image fill the screen, use a scale node after the crop node and set it to "render size" mode.

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.