0
$\begingroup$

I have a scene with a lot of armatures and I want them to be only one rigged big model but merging them with Ctrl+J break all the animations enter image description hereenter image description here

do you have any idea how to fix this?

EDIT: I'm not sure that my post is a duplicate of the other one, I managed to join the armatures by having proper names, then merging the two objects (Crtl+J), Applying transforms, putting two armature modifiers on the object instead of one, and finally, merging the armatures ... The weights are ok, but there is two problems: the action of the second armature is deleted and the armature is like slightly deformed enter image description here,

to fix the action missing I've copied the action before the merge and paste it in the graph editor after the merge, at first the animation kinda looks like it works, but then it goes all over the place ...

EDIT2: so it's not possible to merge armature with the actions attached to it, plus merging armatures with scales not applied properly (and I can't apply scales on it because it breaks the animations) deforms everything. It seems that there is no solution apart from do all the animations again (1600 frames), something that a can't afford to do, in other words, I'm f****d, its a project I've been working on for weeks and there is no solution.

I'm depressed right now 😢

$\endgroup$
2
  • $\begingroup$ You could try merging the armatures into groups. That might work a little bit better than one whole group. $\endgroup$
    – Grace
    Oct 22 '19 at 1:33
  • 1
    $\begingroup$ I'm not sure it's a good idea, it's going to make your work much harder in my opinion. Besides that, in 2.8 you can switch several armatures to Pose mode $\endgroup$
    – moonboots
    Oct 22 '19 at 7:17

Browse other questions tagged or ask your own question.