0
$\begingroup$

enter image description here

Hi Guys,

I was following a tutorial by Remington on Youtube [Smoke Fluid][2], I followed it exactly step by step with out changing anything. The only difference was that he was using Blender 2.79 and I am using 2.80.

The problem that I faced was that when I was previewing the smoke animation in Cycles view it wouldn't render the smoke color transition, I even tried sticking to one color but as you can see from the image above that I was unsuccessful. I have no idea why this isn't working, I tried changing the color by selecting the domain and then going into the shader editor but then the transition of color would not appear instead it would just switch to another color.

If anyone can troubleshoot this and help me I would really appreciate it.

Attached the blend file as well.

$\endgroup$
  • $\begingroup$ Please share your file at: blend-exchange.giantcowfilms.com $\endgroup$ – FFeller Oct 21 at 16:52
  • $\begingroup$ I just did it, thank you for letting me know. $\endgroup$ – Saad Ali Khan Oct 21 at 18:09
  • $\begingroup$ You can move in the shader editor by hold the middle mouse button and move the mouse. You navigated to a wrong place, that's why you see nothing in the shader editor. If you hit the home button, the view will snap to see the whole node layout. The principled volume shader node can adjust the smoke's color, it worked for me with your file. $\endgroup$ – FFeller Oct 21 at 19:36
  • $\begingroup$ I made the changes to the volume shader node but it does not achieve the tutorial result, I keyframed it and it just transitions from one color to another. Were you able to replicate the effect of the tutorial link that I shared. Could you please share the blend file with me with the changes that you made to achieve the effect. Thank you $\endgroup$ – Saad Ali Khan Oct 21 at 21:56
  • $\begingroup$ I found it. So if you want to change only the new, inflowing smoke's color you have to use the Smoke Color parameter of the flow object. But don't decrease the density to 0. And in the domain's shader's Color Attribute use only small letters don't use capitals. And of course bake the simulation again after the modification. $\endgroup$ – FFeller Oct 22 at 18:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.