0
$\begingroup$

This question already has an answer here:

Sorry in advance if this is a duplicate, but I have read anything I can find with "Object missing in render".

I am doing the updated blender 2.8 doughnut tutorial.

My Icing for my Doughnut is missing in action.

My icing appears just fine in the viewport, including in render mode. doughnut

However if I do an actual render: dougnut render

It does not seem to be disabled, these are the setting I have already checked and they all seem to make sence.

settings 1 settings 2

$\endgroup$

marked as duplicate by Robert Gützkow, Duarte Farrajota Ramos Oct 21 at 12:33

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • $\begingroup$ Did you use Texture paint for the icing? $\endgroup$ – Lukasz-40sth Oct 21 at 8:31
  • $\begingroup$ Not I sculpted it, and created materials, but not done a texture paint yet. $\endgroup$ – Gwilym Oct 21 at 8:34
  • $\begingroup$ I have painted vertex weights over it for the sprinkle/particle density but thats it. $\endgroup$ – Gwilym Oct 21 at 8:34
1
$\begingroup$

However I have not watched this tutorial but it seems particle system is used for sprinkles on ice and I think You Have Disabled the 'Show Emmiter' Option in Particle settings but in viewport display it is enabled that's why this ice is shown in viewport but not in rendered view

for emmiter ie; ice to be visible in rendered view just go to particle settings and in render check "show emmiter " and this will work

Screenshot

$\endgroup$
  • $\begingroup$ This was the fix ! Thank you $\endgroup$ – Gwilym Oct 21 at 14:34

Not the answer you're looking for? Browse other questions tagged or ask your own question.