0
$\begingroup$

I'm fairly new to Blender, running 2.80 and trying to learn some hotkeys so i think i may have mashed a key, turning on a feature or option in one of my scenes that's now driving me crazy.

Imagine i have a scene with a cube and a plane. The whole cube is above the plane. If i go to top view and try to move the cube in X or Y axis (via G >> X or Y), the cube appears to move as expected in the top view, but when i go to side or front view the cube has dropped so the the centre of the cube (which is the origin) is now at the level of the plane (i.e. half the cube is above the plane, half below).

Also, if i'm viewing the scene from an angle and try to move the cube in Z (via G >> Z), the cube actually appears to slide along the plane in X or Y before reaching the edge of the plane, and then it starts to move in Z. Deleting the plane allows the cube to start moving in Z correctly, but as soon as i add a new plane the same thing happens.

As you can imagine, this is making it very difficult to position objects! Any ideas what i've done and how to stop it?

$\endgroup$
  • $\begingroup$ Maybe you have Snap (Header>Magnet) switched on, with 'Face' as target? Holding Ctrl during a move flips it from its set state. $\endgroup$ – Robin Betts Oct 19 at 20:05
  • $\begingroup$ The Most Possible Reason is Snapping try turning it off $\endgroup$ – Rakesh choudhary Oct 20 at 5:30
1
$\begingroup$

Sounds like you have some kind of snap setting on. Look at the snap (magnet) icon in the top,center of your 3D view. Make sure it is off.enter image description here

$\endgroup$
  • $\begingroup$ thanks, that's fixed it. $\endgroup$ – alfie-t Oct 20 at 10:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.