0
$\begingroup$

I am doing the Blender Guru Donut tutorial - in my viewport, if I click on rendered view everything looks fine, but when I go to actually render the image, only part is rendering. Did I click some button by accident that is making this happen, and if so, how do I fix it?

The top is a screen shot of my viewport, the bottom is a render.

Thanks for helping a noob![enter image description here]1

$\endgroup$
  • $\begingroup$ It could be a lot of things, try to see if in the outliner some meshes has a crossed camera on the right. If so that means is not gonna be rendered. $\endgroup$ – Igor Svara Oct 19 at 19:49
1
$\begingroup$

Found the answer - in the outliner I had an object that had the "eye" turned off so that it wasn't visible in the view window, but it was part of another collection that was turned on, so it became visible in the rendering (Donut was peeking through it). The collection needed to be turned off (uncheck box) and the problem stopped. Thanks to Igor Svara for his help.

$\endgroup$
  • $\begingroup$ Your image looks great for a beginner. :) $\endgroup$ – Millard Oct 19 at 22:21
  • $\begingroup$ Thank you - that's very encouraging! $\endgroup$ – JoeGideon Oct 19 at 22:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.