0
$\begingroup$

Can anybody tell me how to avoid these nasty artifacts that make the flag look like it is broken on the folding part. They are shown in the Viewport and final rendering. Here is a still from the 15 second animation. I should mention that I created this flag with the "Import>Images as Plane" add-on.

enter image description here

It is a simple mesh, just a plane with subdivisions. The problem began when I started messing with the Force Fields and Physics.

enter image description here enter image description here enter image description here

$\endgroup$
  • 1
    $\begingroup$ If it looks broken, it problay is ... you sure that mesh is fully robust to start with? Maybe make a test blend file with just the mesh and upload to blend-exchange.giantcowfilms.com $\endgroup$ – Merlin Oct 18 at 23:29
  • $\begingroup$ I haven't seen this behavior if there aren't splits in the mesh. Maybe try selecting all vertices, pressing Alt+M and selecting merge by distance to see if they're all unique or if there are some vertices that are doubled up. Down at the bottom it will say how many vertices were removed. $\endgroup$ – Blazer003 Oct 19 at 6:04
  • $\begingroup$ I did the "Merge by distance" thing but it didn't help. The issue is more noticeable when viewed from the back (fourth image above). $\endgroup$ – Tony Tech Oct 19 at 14:16
0
$\begingroup$

After further investigation and testing, I discovered that the artifacts were created by the "Blend Mode" settings in the "Material" tab. Selecting "Opaque" instead of "Alpha Blend" seems to fix the problem but creates a different type of artifact that could be corrected by checking the "Backface Culling" button which once again brings other sort of issues.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.