0
$\begingroup$

I don't understand how smoke is supposed to work in Blender 2.8 (Cycles rendering). No matter what I do, I cannot get a render of smoke. This is extremely weird, since the smoke renders perfectly fine in the 3D viewport: enter image description here

I scoured the net and found this node setup that was supposed to fix the issue, but it doesn't actually do anything:

enter image description here

I followed the steps from this tutorial:

  1. Add object
  2. In object mode, Object -> Quick Effects -> Quick Smoke

And immediately, the effect will work in the 3D viewport in all modes, but it will never render. Please help me, I've been trying to solve this for 3 hours and nothing helps.

| improve this question | | | | |
$\endgroup$
2
$\begingroup$

I tried making a smoke scene to see if I could answer this, and I had the same problem, I fixed it by baking the smoke simulation. (go to the physics tab of the domain cube and under cache press bake.

I hope that fixes the problem.

As a side note, for an easier smoke and fire material, you can use the Principled Volume BSDF. This can be used for smoke and fire.

Here's a picture of the node set up and the result.enter image description here

The two settings you can change to change the look of the smoke is color and density. I hope this is helpful to you. :)

| improve this answer | | | | |
$\endgroup$
  • $\begingroup$ +1 for recreating the problem from scratch $\endgroup$ – Moog Oct 18 '19 at 18:47
  • $\begingroup$ hot damn, it works ! Thank you so much! $\endgroup$ – Axel Oct 18 '19 at 18:48
  • $\begingroup$ Glad i could help. :) could you mark it as accepted so people will know it has been answered? (plus it gives me extra reputation points, which are useful for bounties) :) $\endgroup$ – Millard Oct 18 '19 at 19:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.