0
$\begingroup$

everyone!

Im testing for the first time with fluid simulations and i was trying something very simple but im getting a really odd result:

offset fluid

I dont know why but my fluid is placing above 0 in Z axis. All my objects, including the Domain object are perfectly snapped to 0 in Z but i´m still getting this result.

It has something to do with resolution or preview display or what?

Thanks!

$\endgroup$
0
$\begingroup$

The fluid sim works by breaking the world down into small cells that fluid can flow into or out of. Obstacles, like your cubes, prevent the fluid entering some of these cells. If an obstacle is present in a cell, fluid cannot enter it, even if the obstacle only occupies a small portion of the cell. The gaps you see are the differences between the position of your obstacles and the boundaries of the cells that the fluid sim is using.

You can reduce the size of these gaps by increasing the resolution of the fluid sim because that reduces the size of the cells used (which means more memory is required and more calculations must be performed, so the sim will take longer to bake).

Alternatively you can move the floor up a little bit after baking the sim, or create a new plane obstacle and place it slightly below your current floor.

$\endgroup$
0
$\begingroup$

That danged Fluid Simulator. I don't know how many hours I spent trying to patch holes that didn't even exist in vessels that seemed to just want to ooze fluids, and trying to force the fluid down a hole, instead of all over the sides of the object.

The two biggest factors I found are Solidify and Air Bubbles.

It appears you already have done the Solidify to your vessel, but if not, it's in the Modifiers tab.

Even with that, fluid wants to avoid the vessel opening, and leak out of places when it does go in. So, the other factor is in the Boundary section of the Fluid Domain's Physics tab. This seems totally counter-intuitive to me, but it seems by UN-checking the "Remove Air Bubbles" check box, it works better ... still not perfect.

Fluid Domain Boundary Section

For this test, I didn't really do it right, and did not want to spend a lot of time on it. I apologize. This is at mostly the basic, default parameters, except I set it for 96 frames, and set the "Inflow" to -3m/s on the Z axis, (and, of course, set the "faucet" Fluid Physics type to Inflow as a Shell), but hopefully you can see the difference in how much fluid fell out of the vessel and into the Fluid Domain box here ...

With Remove Air Bubble Checked

... and here where I UN-checked Remove Air Bubbles.

Remove Air Bubbles UN-checked

Here is the wire frame view, so you can see the crazy shape of the vessel better. As I said, I rushed through this a bit too much. I didn't even do the Solidify, as I suggest.

enter image description here

I would think the air bubbles would displace the fluid, and, without them, draw more fluid into the vessel, but the complete opposite seems to be true, (which is why it took me so long to try unchecking that box).

For this test, I should have made the opening a bit larger, but wanted to make sure it failed, and it did. Had I tuned it, I think I could have gotten it all to flow into the vessel, as I've had some success in the past by unchecking that box and solidifying my vessel object.

Both of the renders above were at the exact same frame of the simulation ... um, frame 27, I believe. I just picked one at random, and left it there before the second Bake and Render, after only unchecking that box.

Besides leaving all the rendering parameters at their default, low resolution, I also left everything in the Physics at the default Partial Slip parameters, but you can also try changing the "Amount" of "Partial Slip".

No matter what, we are still going to be finding issues with the Fluid Simulator ... if not keeping it in vessels, the viscosity thing. Just keep plucking at it.

Now, about that danged Fire and Smoke Simulator ...

$\endgroup$
  • $\begingroup$ Those pesky bubbles ... have you tried FLIP Fluids add-on? $\endgroup$ – Merlin Oct 18 at 21:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.