I've worked on a scene on my 2015 MacBook Pro and it looks great, but takes too long to render.

I bought an RTX 2080 for my PC and the volumetric scatter is barely visible.

Why is my RTX 2080 performing worse than my 4+ year old laptop and how can I get the volumetric scatter to show correctly?


So I found one problem. For some reason all the light sources are reset to default values at 100w.

Changing the values to the values I initially had set them to does not make a difference.


Now when I switch to CPU rendering the image is displayed correctly. But GPU rendering still renders incorrectly.


I've narrowed it down to CPU vs GPU. When rendered on the CPU it looks exactly as I expect, but on the GPU it doesn't look right.

  • $\begingroup$ The output result shouldn't depend on the hardware. In order to render on the GPU you need to select it has compute device in the preferences and select GPU as device in Cycle's render settings. $\endgroup$ – Robert Gützkow Oct 17 '19 at 18:12
  • $\begingroup$ It is on GPU Compute, Feature Set: Supported. Literally nothing is changed. The exact same file. $\endgroup$ – xaid Oct 17 '19 at 18:15
  • $\begingroup$ Make sure that you have the latest graphic drivers installed. If that doesn't fix it, please write a bug report and add a minimal working example project that shows CPU and GPU rendering with Cycles produce different results. $\endgroup$ – Robert Gützkow Oct 17 '19 at 18:53
  • $\begingroup$ I'm suspecting that 2.8 does not even support RTX 2080 properly. I still need to do some testing before I write the bug report. Can you share the link to bug report? $\endgroup$ – xaid Oct 17 '19 at 18:58
  • $\begingroup$ The RTX 2080 is supported. Make sure you have the latest driver installed (nvidia.com/Download/index.aspx). In case this still happens with the latest driver, open Blender and go to Help > Report a Bug. Make sure to fill out all the information in the template. $\endgroup$ – Robert Gützkow Oct 17 '19 at 19:03

Problem solved by changing sampling integrator to Branched Path Tracing.

This is not needed when rendering on the CPU, but apparently required when rendering on the CPU.

I found the solution here: Volumetric scatter shader does not show light focused through lens correctly


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.