0
$\begingroup$

I want to create a collision of two objects when one of them is weighted much more than the other. In the example attached the cube is weighted 150 Kg and the sphere only 1 Kg. I expected the cube to barely move after the collision since it weights much more than the sphere but it is not the case. The friction of the plane is set to default and equal to 0.5. How can it be done? how to make collisions look more realistic in terms of differently weighted objects interaction.

enter image description here

$\endgroup$
  • $\begingroup$ have you tried increasing friction? maybe it's just too low $\endgroup$ – Luciano Oct 16 at 12:24
0
$\begingroup$

I am on Blender Version 2.81.11 and everything worked as expected Groundplane is passive, the sphere active with mass is 1kg and Cube is active with 150kg. everyting else is set to Default. I keyframed the first 10 frames to make an initial Velocity for the sphere as stated here
How can I add motion to a rigid body?

the sphere hits the cube but the cube does not move. from around 30 kg for the cube a got some slightly motion after the hit.

$\endgroup$
  • $\begingroup$ did you change the rigid body kinematics to false i.e. turned off the animated property before the collision? $\endgroup$ – AvivSham Oct 16 at 13:29
  • 1
    $\begingroup$ for the Sphere i ticked the Animate Checkbox, then keyframed the position 10 Frames and keyframed the Animate property to off. then from frame 11 the RigidBodySim takes over. It is a few units away from the Collison, so the RBD Sim guids the process and not the keyframes $\endgroup$ – Master Heavy Oct 16 at 13:39
  • $\begingroup$ I suspected this is what I was missing. let me try it and get back to you. $\endgroup$ – AvivSham Oct 16 at 13:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.