0
$\begingroup$

Started using Blender yesterday (Blender 2.8 on windows 10 system) and created two small blender scripts.

Today I opened blender and the texteditor and I wanted to open a previously made blender script but the list is empty. As you can see from the photos, I have two scripts in the folder but even with that directory open in blender it doesn't see the scripts.

I have checked all types to be viewable.

What am I missing?

enter image description here

enter image description here

$\endgroup$
  • 1
    $\begingroup$ Do they have a file extension? It should be createmonkey.py and mirrorscript.py $\endgroup$ – Tiles Oct 16 at 6:38
  • $\begingroup$ Hero! That was it. I added .py to the filenames and now they show up. Doesn't blender automatically save them with an extension? Have to add them yourself? $\endgroup$ – JeeperCreeper Oct 16 at 23:40
  • $\begingroup$ @tiles how can I upvote your comment and mark this solved, thats the least i can do for you. $\endgroup$ – JeeperCreeper Oct 16 at 23:42
  • $\begingroup$ I have added it as an answer now so that you can vote it :) $\endgroup$ – Tiles Oct 17 at 6:34
1
$\begingroup$

The file needs to have the proper file extension. Files without the proper file extension gets filtered out in the dialog.

Or you need to turn off the file filter. This can be done up right in the filter settings. The better way is to name the scripts proper though, with its correct file extension. Python scripts ends with *.py

enter image description here

$\endgroup$
  • $\begingroup$ Thanks again, that answered my question. Again, I assumed typing just the filename would suffice and after pressing enter Blender would automatically add the .py part. learned something. :) $\endgroup$ – JeeperCreeper Oct 18 at 4:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.