1
$\begingroup$

enter image description hereenter image description hereenter image description hereenter image description hereHi Blender StackExchange, can you help? I'm currently trying to create glass from a solid object by turning transmission up to 1.0. The rendered image I'm getting is a solid dark grey and not transparent at all. Thank you.

$\endgroup$
  • 2
    $\begingroup$ Welcome to Blender on Stack Exchange. It would be extra helpful if you can upload a sample blend file and/or some screenshots of your material setup to help us solve this. $\endgroup$ – Moog Oct 14 '19 at 19:57
  • $\begingroup$ Thanks Merlin, screen grab added. Any help gratefully received. $\endgroup$ – Rhona Hayes Oct 16 '19 at 10:54
1
$\begingroup$

So "this just works" when rendering with Cycles, but Eevee requires a bit more setup.

Try the following settings:

  1. Render → Screen Space Reflections ON
  2. Render → Screen Space Reflections → Refraction ON
  3. Material → Surface → Principled BSDF → Transmission 1.000
  4. Material → Surface → Principled BSDF → Roughness [Cycles Only]
  5. Material → Settings → Blend Mode OPAQUE [or ADDITIVE]
  6. Material → Settings → Screen Space Refraction ON
  7. Material → Settings → Refraction Depth PLAY WITH IT

You can also check out the documentation for:

You should get something like this in Render Mode, I didn't have the patience to model a teacup, so the default cube is all you get :)

enter image description here

$\endgroup$
  • 1
    $\begingroup$ Thanks Merlin, it certainly looks better but it's still pretty weird. Is there a way I can share another screen grab with this response on StackExchange do you know? $\endgroup$ – Rhona Hayes Oct 16 '19 at 12:01
  • 1
    $\begingroup$ I am in lock dev mode, as it looks so much better than render mode. See new edit above. $\endgroup$ – Rhona Hayes Oct 16 '19 at 12:21
  • 1
    $\begingroup$ bing to the o. Except what's the difference in my shadow? Also please can I get help with one more thing Merlin? As you can't copy an object over to another Blender doc, can you please tell me how to take off/reset whatever I've weirdness I've managed to appy to my model so that I can apply this new set? Or do I just start again? $\endgroup$ – Rhona Hayes Oct 16 '19 at 12:40
  • 1
    $\begingroup$ thank you for the links. They're very informative. $\endgroup$ – Rhona Hayes Oct 16 '19 at 12:52
  • 1
    $\begingroup$ Aha! Brilliant! I can't chat in the chatroom until I have 20 reputation but I have a few more questions. Is there I way I can ask them? $\endgroup$ – Rhona Hayes Oct 16 '19 at 13:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.