0
$\begingroup$

Eevee now supports Movie Images, but I can't get it to handle transparency and the shadows 'not created' by transparency.

I have a plane with a movie texture on it - a moving person, with transparency around the person (from a green screen).

The viewport and rendered output is fine (once I'd ticked all the options listed below) EXCEPT for the shadow: It gets the shadow of the image plane (a rectangle) rather than just the shadow of the figure. A sort of 'reverse vampire' effect. Shadow is correct in Cycles as the render engine, but of course Cycles is much slower.

Is there some setting I'm missing, or has this just not been implemented in Eevee yet?

[Settings: I get a rendered image sequence, .PNG with transparency (from green screen footage), and use it as a movie texture on a plane in my model.

  1. Edit.UserPrefs.Addons.'Images as Planes' add on - check this box.
  2. File.Import.'Images as Planes' - check 'Animate Image Sequences' and 'Material Settings.Shadeless'.
  3. Click on one of the .PNG images in the sequence, then 'a' to select all. Confirm (button top right window) -> a plane with animation on. This can be selected, resized, moved etc.

All good.

Then tick all the requirements to get movie image transparency to display transparent not black:

  1. Properties.Material.Settings.Blend Mode.Alpha Clip
  2. Properties.Output.Post Processing - uncheck Compositing & Sequencer. All looks great, apart from the shadow, which is of the image plane (rectangle) not the person in it.]
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.