0
$\begingroup$

I have a simple 3D model where all vertices are on the grid. The model origin and 3D cursor are both on the grid at 0,0,0. I have Absolute Grid Snap turned on.

When I box select and translate it only snaps the center of the selection to the grid. I want all points to snap to the grid regardless of where the centre is. It would suffice if only one point snaps to the grid as all other points will follow.

This isn't an issue where the center of my box selection happens to fall exactly on the grid already, but where the center of my box selection is not on the grid, any movement causes all selected vertices to immediately jump off the grid. This is quite frustrating.

I have changed the Pivot Point to individual origins but as stated in Blender this only effects rotation/scaling, not translation.

How can I translate based on a vertex of a selection or even the outside bounds of the selection, instead of translating based on the center of the selection?

I should mention I'm using 2.8, but this problem also existed in 2.79b.

$\endgroup$
  • $\begingroup$ If I turn off Absolute Grid Snap, I can use snap to increment to move around points already on the grid, but then if I want to move a point that's not on the grid to the grid I need to turn it back on again. It's quite annoying turning it off and on all the time. I feel that it should snap all points to the grid when on even with multi selection. $\endgroup$ – Steven C Oct 14 at 4:44
0
$\begingroup$

You can move the Origin of the object, which is currently your "center of object", to the grid. In Edit Mode, select a vertex on the grid, then press Shift S and Snap to Selected. Then in Object Mode, go to the Tools Tab of the Tools Editor, Set Origin, and Origin to Cursor. I'm in 2.79 - hope you can find the commands in 2.8.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.