0
$\begingroup$

This question already has an answer here:

I have a model of the TARDIS from the TV series 'Doctor Who' and I'm trying to apply a UV texture to one of the panels. In the 3D view it looks like I want it to. (if you ignore the pink textures)

The correct mapping in viewport The correct mapping

But, when I render it, the UV texture becomes distorted like this:

The distorted render

This part is important: I got this model from the internet and I don't know how the textures were applied to the model (I know it isn't UV mapping) and UV mapping is the only texturing method I know in Blender. There was originally a texture on that panel but I wanted to swap it for a better one (the one I am applying now)

$\endgroup$

marked as duplicate by gandalf3, cegaton, David, Ray Mairlot, iKlsR Sep 4 '14 at 1:22

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • $\begingroup$ It's hard to tell without a blend file or more information (screen grabs) on how the faces are UV unwrapped or how the material/textures are applied. $\endgroup$ – cegaton Sep 3 '14 at 15:00
  • $\begingroup$ You should add which renderer you are using, cycles or blender internal? This is indeed a strange issue however. $\endgroup$ – beiller Sep 3 '14 at 15:03
  • $\begingroup$ The blend file is here if you want to take a look at it: cydialstream.x10.mx/dl/TARDIS.blend And I know the UV is correctly applied becuase I've checked the vertices of the map against the texture and it matches up. I don't know how the other textures were applied though, that was what the original author did. $\endgroup$ – Pyroglyph Sep 3 '14 at 15:04
  • $\begingroup$ @beiller I'm using the 'Blender Render' rendering engine. I never knew how to use Cycles. $\endgroup$ – Pyroglyph Sep 3 '14 at 15:05
2
$\begingroup$

Your problem appears to be the UV coordinates you have assigned.

Select your "Panel" material. Click the textures tab. Scroll down to "Mapping". Set coordinates from "Generated" to "UV".

This will solve the issue.

To clarify the problem:

When you generate UV coordinates, you also have to go into the Texture's settings, and say you want to use those UV coordinates to map it, not the default generated coordinates.

$\endgroup$

Not the answer you're looking for? Browse other questions tagged or ask your own question.