0
$\begingroup$

I use Blender 2.8 and I made a lot of successful holes with the boolean modifier. Today is not one of those days and I don't know why.

I have a simple rectangular 2D object in which I need to cut 4 cylindrical holes.

This is what I have done:

  • I've used CTRL+R to make new lines on the rectangle that intersect exactly where I should place the holes

  • I moved the cursor to each point and created a cylinder

  • CTRL+J to make a single object from the 4 cylinders

  • I used a boolean modifier on the rectangle and applied it to the cylinder with the operation "Difference" but I didn't get the holes

This is the Blender file:

What have I done wrong? Is there a way to place the cylinders exactly where they should be without using CTRL+R? If I don't use CTRL+R the holes get done but then they are not in the right place...

Thank you.

$\endgroup$
  • $\begingroup$ Please use blend-exchange.giantcowfilms.com for uploading files. As your question doesn't have any images it solely depends on the file attached. Hence if the file is gone the question isn't clear any more. Better yet include a screenshot of the model additionally to the file $\endgroup$ – Mr Zak Oct 12 at 16:45
  • $\begingroup$ blend-exchange.giantcowfilms.com doesn't seem to work, it says. It writes "Files may take some time to process" but 5 minutes have passed since I try to upload a 600KB file. $\endgroup$ – Victorqedu Oct 12 at 20:04
  • $\begingroup$ Press Upload button first... That is warning, not a process description $\endgroup$ – Mr Zak Oct 13 at 10:08
1
$\begingroup$

Boolean modifier -> turn overlap threshold all the way down to 0. Since your objects are so small in the scene blender considered the faces as overlapping (i.e your rectangle was too thin).

$\endgroup$
  • $\begingroup$ It didn't worked only 2 out of 4 holes got made after turning threshold to 0. I also tried to increase the size of the objects 100 times and still the holes didn't appeared. $\endgroup$ – Victorqedu Oct 12 at 18:30
  • $\begingroup$ also your boolean modifier wasn't targeted in your file $\endgroup$ – Arthur Blaquart Oct 12 at 19:17
  • $\begingroup$ I targeted the cylinders right before pressing apply. I updated the file from the link with the objects resized and the cylinders targeted in the boolean modifier. $\endgroup$ – Victorqedu Oct 12 at 20:02
  • $\begingroup$ I solved the problem but I don't think is the right way: I deleted all the lines that I created using CTRL+R and the boolean modifier started to work. I actually made the lines disappear by selecting all the faces from that side of the rectangular object and pressing "Dissolve faces" $\endgroup$ – Victorqedu Oct 12 at 20:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.