1
$\begingroup$

Sorry if I'm a complete noob, this is my first time using blender.

So far, I've managed to import the image as a plane with the addon (import/export image as a plane), and now want to export it out as a glTF file type. Before export However when i do so, the exported glTF does not have the image I've placed and is empty. After Export I've found another forum (link) that guy stated he had a similar problem to what I was having. However, the solution which requires to uncheck/disable the transparency/z transparency, but is missing from my blender project - as seen from the first image above while in materials tab.

Maybe I am at the wrong part of blender or is there a newer solution to this issue?

$\endgroup$
2
$\begingroup$

The imported image is using the "Diffuse BSDF" shader, but glTF has a PBR material system that is based on the "Principled BSDF" shader.

Luckily, you can just swap one for the other to get this working. Use the "Shading" tab at the top of Blender 2.80 to get to this area, and replace "Diffuse BSDF" with "Principled BSDF":

Shader changed to Principled BSDF

Additionally, if your image has any translucent parts, set "Blend Mode" to "Alpha Blend" in the material settings (Eevee only) like so:

Alpha blending settings for transparent images

$\endgroup$
  • $\begingroup$ Thanks emackey, I did what you typed and it works! Cannot mark your answer as resolved though since I asked this question while being a guest. $\endgroup$ – histora Oct 14 '19 at 2:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.