1
$\begingroup$

The emitter can emit particles when it's not connected to animation node. but when I connect it to the animation node with position transforming, the particles can't fly, they all are stick to the emitter object.

Anything I missed or any suggestion? thanks.

enter image description here

$\endgroup$
1
$\begingroup$

Blender's particle system integrator resets the simulation every time an unexpected change in the object's transformation happen. Try moving the object mid-simulation and you will find that the particles resets. As far as I know, to work around this, you need to bake the animation into key-frames so that Blender's know about the transformation in advance.

|improve this answer|||||
$\endgroup$
  • 1
    $\begingroup$ Thanks for the suggestion. I clicked the "bake to keyframes", but it's not working neither. the timeline is not written to "red". $\endgroup$ – blackgun Oct 10 '19 at 16:57
  • 1
    $\begingroup$ I found it only work when I do this way: step1) run with "auto execution" enabled step2) disable "Auto Execution" . step3) bake . Is that a right approach? $\endgroup$ – blackgun Oct 10 '19 at 17:08
  • 1
    $\begingroup$ @blackgun Yes, you have to disable auto-execution in the second run, otherwise baking to keyframes would be useless. $\endgroup$ – Omar Emara Oct 10 '19 at 18:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.