0
$\begingroup$

When I press F12 Blender 2.8 it doesn't render what I'm currently looking at. How do I select what to render when I press F12?

EDIT: I didn't explain the situation well enough not that I'm reading it back. The camera is in the 'layer' that I'm watching. The 'layer' that gets rendered with F12 doesn't have a camera object in it nor is it the 'layer' that I'm watching.

$\endgroup$
0
$\begingroup$

You probably need to move the camera to the position that you are looking at; you can move the camera manually like an object or you can press Ctrl + Alt + Numbpad 0 to move the camera to your view position.

Hope that helps.

Good Luck

$\endgroup$
  • $\begingroup$ I didn't explain the situation well enough not that I'm reading it back. The camera is in the 'layer' that I'm watching. The 'layer' that gets rendered with F12 doesn't have a camera object in it nor is it the 'layer' that I'm watching. $\endgroup$ – 211086004 Oct 9 at 13:41
0
$\begingroup$

Hit zero and go to the camera view.

So—you see your view as you’d like to render it, right?

If so, and it’s rendering something else, you MIGHT have an issue with hidden layers. Have you hidden any elements? Hit Alt-H to unhide everything.

If this is the problem, do not HIDE these layers as hidden layers are still active render layers. Deactivate them by moving them to their own collection and unchecking the active box in the Collections panel.

This might also have to do with something called “Restricted Render”. In 2.79 there was a shortcut (which I do not know off the top of my head for 2.8). At least in 2.79, it was easy to accidentally restrict certain layers from rendering.

If your whole camera view is different in the render, then something a little more complicated is up.

John

$\endgroup$
0
$\begingroup$

I don't believe the old concept of a layer has survived from Blender <=2.79 to Blender 2.8+. As far as I am aware, the functionality old layers provided has been superseded by collections. There is a notion of View Layers (see: https://code.blender.org/2017/09/view-layers-and-collections/), but I believe this refers to Scene-level collections of objects, which may not be what you mean by 'layer'.

To control which collections (or objects within collections) in the current scene will appear in a render, you can either enable/disable a collection (this occurs in the "check mark" boxes in the Outliner in the image below) or turn on the ability to see the "Disable in Renders" button from the "Restriction Toggles" tab of the Outliner, and then use that Disable-in-Renders toggle to control what is rendered.

I've circled the Restriction Toggles tab in red, and instances of the Disable-in-Renders toggle in yellow, here:

enter image description here

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.