0
$\begingroup$

I have created a window in my project, and it's working fine, but in the reflection and when I look from the inside, through the window, a "world" is shown that I only see in the reflection and when I look through the window. I changed the environment texture to see if that would change anything. It did just that, but I don't want any environment to show in the reflection, or through the window. Is there an easy way to fix this?

Thanks ;)

$\endgroup$
  • $\begingroup$ An Environment Texture wraps around the entire scene, so of course you can see it reflected. An alternative would be to not use Environment Texture, and add an "Images as Planes" object (you'll need to enable the images as planes add-on in Preferences). That will let you add a background image without it wrapping around the scene, although you won't be able to use HDRI images for that purpose due to the distortion. $\endgroup$ – Phil Rogers Oct 8 at 9:57
1
$\begingroup$

You could turn of the glossy (reflective) rays and the camera (directly visible) rays for the world in the cycles settings panel.

cycles settings of the world

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.