0
$\begingroup$

I have 'Vertex Group Weights' enabled in edit mode but for some reason the weight values aren't showing up on the mesh whenever I rotate a bone. I can assign a group of vertices a weight of 1 and it stays blue, and even when I cancel the rotation/relocation of the bone and go back into edit mode, it still hides the weight values.

Vertex group with assigned weights coming up as entirely blue

I tried changing the 'zero weights' selection to Active and All but the problem was still there. Is there anyone who knows how I could fix this?

Edit: Part of the project I was working on:

$\endgroup$
  • $\begingroup$ I don't think you can use the Shading > Vertex Group Weight in conjonction with bone selection. It looks like it's only made to display the selected vertex group in the Properties editor > Object Data > Vertex Groups. If you want to see the weight of bones on the mesh you need to select the armature, shift select the object, and then switch it to Weight Paint mode $\endgroup$ – moonboots Oct 8 '19 at 6:20
  • $\begingroup$ Thank you for answering! I probably should have included that once I go into edit mode, I don't have any bones selected. If I do anything at all with the armature and then go back into edit mode on the mesh (with or without shift-clicking) I can go through the entire list of vertex groups in the properties editor and none of them will show up. I don't think this has to do with the bone selection because I can make it happen with as little as simply selecting the armature in object mode, going back into edit mode for the mesh - all the vertex weights become hidden. $\endgroup$ – Sifty Oct 8 '19 at 8:30
  • $\begingroup$ could you please share your file or at least a part of it? blend-exchange.giantcowfilms.com $\endgroup$ – moonboots Oct 8 '19 at 8:34
  • 2
    $\begingroup$ maybe it's a bug because if in Viewport Overlays you switch from Vertex Groups Weight > Zero Weight > None to Active, then back to None, it works... $\endgroup$ – moonboots Oct 8 '19 at 11:44
  • $\begingroup$ @moonboots There does seem to be a bug when initially enabling the weights option, but once you change the display option to make it work, it continues to work. $\endgroup$ – sambler Oct 20 '19 at 6:03
0
$\begingroup$

Every modifier has three or four display options.

armature modifier

The first one shows the result of the modifier when rendering.

The second shows the result in the viewport.

The third shows the result while in edit mode

The fourth shows the result on the edit cage while in edit mode. Enabling this only works when the third is enabled.

By having the edit mesh options disabled, you will only see the undeformed mesh in edit mode. Enable both of these to have the edit mesh follow the armature.

While in edit mode, selecting bones has no effect on the display of vertex group weights. Select a vertex group in the mesh properties to change the weights displayed in the viewport.

vertex group selection

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.