1
$\begingroup$

this post may seem repetitive but among many with this kind of issue none of them can help me. I already updated both drivers (Intel and Radeon) and BIOS, installed Radeon ProRender + libraries and still got the problem. I checked about both Radeon 520 and Intel UHD 620 and they support openGL 3.3. Intel driver is already disable here to don't et it create any conflict. Please, I don't know what else I can do.

enter image description here

enter image description here

$\endgroup$

2 Answers 2

1
$\begingroup$

Sorry guys, just found the solution. In my case, Blender runs just after a complete uninstall (disabling not enough) of Intel driver.

$\endgroup$
1
$\begingroup$

I have analogous situation with Nvidia Quadro P500 / Intel UHD 620. For some reason Quadro is not able to cover requirement of OpenGL 3.3, I believe that it should be working, and Intel UHD 620 should be able to run Blender without any issues too with OpenGL 4.6.

Many people use some shady dll downloaded from suspicious youtube videos, I recommend using some more reliable source as for example https://fdossena.com/). It was working but it was slow as hell.

Then I suddenly notice small text in Nvidia control panel "Windows OS now manages selection of the graphics processor". Then it was matter of seconds to select integrated card and Blender started without any issues.

enter image description here

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.