3
$\begingroup$

I'm trying to "add" an 3D object onto a photo. I have added the photo to the scene in three ways so far, but none of them render (eevee):

  1. Camera > Background Images
  2. Empty a. Add > Empty > Image (Empty gets added to current Collection) b. Add > Image > Backround (Empty gets added to Scene Collection)

These all show up in the 3D View and I was able to align the camera and the object so its perspective matches the scene in the photograph. But when I Render the scene, I only see the object, not the background image.

For the latter, it's simple: Empties are not rendered at all. There are few questions about this, since 2.8 has changed how it handles background images. The most popular seems this one (it includes references to others):

But I seem not to be able to find a method to have the background image render.

Another method might be to use the Compositor (Nodes) to Mix or Alpha Over an Image with the Render Layers. But this does not give the same alignment as achieved with the background image (also this requires that the World background does not get rendered (Alpha channel); for Eevee, this can be achieved by checking Film>Transparent).

What other options are there?

Docs:

$\endgroup$
2
$\begingroup$

To do this without making it the background of your whole scene like handle does, I reccomend the images as planes addon.

This makes your image displayed on a mesh plane, meaning it will show up as desired in the render.

First enable it in the preferences: here

Then just add an image as a plane from the add menu: add menu

And then it should show up in your scene as you want.

$\endgroup$
0
$\begingroup$

From https://blender.stackexchange.com/a/38464/33447:

The alternative is to set the World background:

enter image description here

$\endgroup$

Not the answer you're looking for? Browse other questions tagged or ask your own question.