0
$\begingroup$

when using texture paint I can colour the whole object (in this case its a lightsaber) but when I go in to add detail with a black or any colour the edges become darker all over the object and I don't know why. I first thought it might have been the UV unwrap and when selecting another UV unwrap option like Cylinder Projection it doesn't happen but the texture doesn't go on correctly as in it goes through the other side or something else. I am wanting to do a very basic texture paint with just black in the gaps and I can't figure out how to fix it. If you have any ideas on how to fix it please can you let me know, I have played around with different UV unwrapping but that doesn't seem to take away the problems? Thanks enter image description here

$\endgroup$
  • $\begingroup$ At first glance that seems to be a problem with the margin. Cycles doesn't need a huge margin (the space beyond a seem/island in the UV map) but realtime renderers do. So try to render it in Cycles and see if it goes away. If yes, use your unwrap again and use a higher margin. But if all you're after is darker crevices, may I suggest Vertex paind and select Paint -> Dirty Vertex Colors $\endgroup$ – Frederik Steinmetz Oct 6 at 10:11
  • $\begingroup$ Thanks, Frederik. I tried it rendered and it showed up :(. So annoying. I tried a higher margin and didn't do anything, I tried the vertex paint and that seemed to not get the darkened edges but it wouldn't put down the texture like the texture paint. I was playing around with another object to see what was making this happened and it seemed to be caused by the Offset edge or the Loop cut and slide. This is what I found to cause the problem but might be something else that I haven't found. Do you or anyone know why this is the case? Thanks $\endgroup$ – Reef Oct 7 at 11:44
  • $\begingroup$ It could be lack of topology, try adding a bevel modifier, limit it to angle and increase the resolution to 4, if it's gone, you need more geometry $\endgroup$ – Frederik Steinmetz Oct 7 at 15:22
  • $\begingroup$ That didn't seem to work. It seems to also go away if I take away the subsurface modifier, is their something wrong with the modifier or do I need to add something maybe take something away?? thanks $\endgroup$ – Reef Oct 8 at 5:58
0
$\begingroup$

Since it goes away with a subsurf it is a problem with too little geometry - too few edge loops to get a good interpolation across the edge. You can

  1. Use manual loops along the discs
  2. Use edge split modifier to not interpolate across the sharp edges
  3. Use the Bevel Modifier (if it doesn't work, google how to use it, or send me a screenshot of your settings)

EIDT: I just realized, the subsurf modifier you mentioned might also mess with your UVs, try toggling split UVs in the settings.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.