4
$\begingroup$

I am using Blender in Ubuntu with irie ppa. I've installed Nvidia-cuda-toolkit from irie and bumblebee, then I try to render using cycles but I keep getting this error in the terminal:

CUDA version 4.2 detected, build may succed but only CUDA 5.0 is officially supported

After getting this error, I downloaded Cuda 5 from Nvidia website and tried to install it, but instead got this error:

Unsupported compiler: 4.7.2

Then I tried to install with

sudo ./cuda*.run -ovveride compiler 

Cuda 5 installed correctly, but when I tried to render again with Cycles I got yet another error message (again)

/usr/local/cuda-5.0/bin/nvcc: 2: /usr/local/cuda-5.0/bin/nvcc: Syntax error: Unterminated quoted stringCUDA: failed to find version number in:
CUDA nvcc compiler version could not be parsed.

I removed the Cuda files and tried to install (again), but before installation I tried to choose gcc-4.6

sudo update-alternatives --install /usr/bin/gcc gcc /usr/bin/gcc-4.6 40 --slave /usr/bin/g++ g++ /usr/bin/g++-4.6
update-alternatives: using /usr/bin/gcc-4.6 to provide /usr/bin/gcc (gcc) in auto mode
sudo update-alternatives --install /usr/bin/gcc gcc /usr/bin/gcc-4.7 60 --slave /usr/bin/g++ g++ /usr/bin/g++-4.7
update-alternatives: using /usr/bin/gcc-4.7 to provide /usr/bin/gcc (gcc) in auto mode
sudo update-alternatives --config gcc

and select gcc-4.6 as compiler. After that I try to install Cuda (again) with

sudo ./cuda*.run everything is fine, installation succes.

But, when I try to render my model with Cycles I get the following error (again)

CUDA: failed to find version number in:
CUDA nvcc compiler version could not be parsed.

Can anyone help?

$\endgroup$
3
$\begingroup$

Run nvcc on the command-line with option --version. It should show some version information similar to:

nvcc: NVIDIA (R) Cuda compiler driver
Copyright (c) 2005-2012 NVIDIA Corporation
Built on Tue_Sep_25_09:18:50_PDT_2012
Cuda compilation tools, release 5.0, V0.2.1221

The most important part is the last line Cuda compilation tools, release 5.0, V0.2.1221. Cycles looks for the first part Cuda compilation tools, release. If this cannot be found, then Cycles gives up with the error you pasted.

If it is different (and based on your output the entire version string is even empty), then you need to contact the package creator to report a bug.

| improve this answer | |
$\endgroup$
  • 1
    $\begingroup$ The full command to try is this: /usr/local/cuda-5.0/bin/nvcc --version. The full path may be needed because nvcc is likely not in PATH. $\endgroup$ – brecht Jul 1 '13 at 13:10
  • $\begingroup$ i 've try the code but i getting error :cannot execute binary file. I think i have installed 64bit driver is wrong. I am using Ubuntu 12.10 64bit but running 32bit program. $\endgroup$ – Pandu Aji Wirawan Jul 8 '13 at 3:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.