0
$\begingroup$

I am trying to set up V-Key as shortcut. But it is ignored in Vertex Paint Mode.

In Object Mode, I hover over Vertex Paint, right-click and add shortcut. Great! I hit V-key, switches to Vertex Paint mode.

Now I hover over Object Mode, right-click and add shortcut. Since I am trying to toggle states, I use same: V-Key

enter image description here

But, it does not switch back to Object Mode.

It seems that shortcuts are global, not bound to current view state.

So, can I make V-key a toggle between view modes?

$\endgroup$
0
$\begingroup$

Found it!

It occurred to me I was trying to mimic the Tab-Key. So I looked that up in the Keymap. Then just did the same thing, but for Vertex Painting instead of Editing.

Preferences > Keymap > 3D View > Object Non-modal > Add New

  • Set object.mode_set
  • Assign V-Key binding
  • Then select option to make it a toggle.

enter image description here

Note: In Vertex Paint mode, 'V' is already bound to 'Vertex Section' mask. I removed the default V-key shortcut from Keymap > 3D View > Vertex Paint.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.