0
$\begingroup$

So, I started using blender 2.8 for a while now. And couple of months ago I started experiencing some really weird white dots on x-ray mode in the view-port shading. I use this mode a lot to model assets with reference images. And it's pretty hard to see the shapes I'm modeling with that horrible shading problem. Is it a setting that I have changed by mistake? Or is it just a bug? (thanks for taking your time to read this)

My pc specs: Ryzen 7 first gen, vega 64 (sapphire nitro+), 32 gb ram. enter image description here

Update: I don't like using wire-frame mode, cuz there are some details that I prefer seeing with the solid shading, like good edge flow with smooth faces, or some parts with the curvature on. Here's another example on another file that for some weird reason works just fine, but at times I get the same problem:

enter image description here

$\endgroup$
0
$\begingroup$

Just click off the solid view, whilst in x-ray etc. If you have wireframe mode on instead it should be fine. Hold z-select wireframe, hope it helps. It just happens with solid view.

You seem to not have overlays turned on in the mode you want, in any view etc. I tried it, and it shows the same without overlays. I assume it is wireframe-mode turned on in the overlays above icon, that creates the shading you dislike. Turn it off. Then try changing views.

$\endgroup$
  • $\begingroup$ Check the update I posted, I have another file that works fine, I just don't like to use wireframe mode all the time. It's not fully efficient in certain situations. But thanks for your answer!!! $\endgroup$ – Fernando Andre Morante Oct 3 at 17:46
0
$\begingroup$

Update your Radeon Settings Drivers if you haven't already fixed the problem.

Had this exact same problem and found that you were the only other person that had posted about it on the internet. Turns out, we both have pretty similar rigs (Ryzen 7 1700, Sapphire Vega 64) so I figured it must be a driver issue. I went ahead and updated to 19.11.2 from the recommended drivers and it seems to have fixed the problem entirely. Hope this helps!

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.