1
$\begingroup$

Whenever I go into LookDev mode with this Cynder model I ported from SFM (which was originally an .mesh.ascii file) a strange graphical glitch occurs where I can see faces glitching through each other. enter image description here

This was more obvious in edit mode. enter image description here

In rendered mode it is completely fine, so I don't know what's going on. Because the faces show through each other in edit mode I'm thinking there's something wrong with the mesh but I'm not sure what.

enter image description here

I have many other models that I've imported from SFM into Blender the same way and they've never had this problem before.

Help would be gladly appreciated, please respond asap.

[EDIT] Blender file below:

$\endgroup$
  • 1
    $\begingroup$ Heve you check if there is overlaping faces ? Did you recalculated normals ? Did you remove custom edge split ? $\endgroup$ – softyoda yoann Oct 3 at 8:10
  • $\begingroup$ There are no overlapping faces and recalculating the normals didn't appear to do anything. What is meant by custom edge split and how do I remove it? $\endgroup$ – S.K. Oct 3 at 8:24
  • $\begingroup$ Seeing your edit mode screenshoot, i don't think it come from that, but you can see what it is here : i.imgur.com/NVCdlF5.png $\endgroup$ – softyoda yoann Oct 3 at 12:03
  • $\begingroup$ Another thing you can look for is the clip start and end in the view of N panel i.imgur.com/IAnBRsE.jpg $\endgroup$ – softyoda yoann Oct 3 at 12:04
  • $\begingroup$ I've also tried that, it didn't seem to work either. It just changed the boundaries of what could be viewed. I'm at a complete loss as to what could be going on with this. $\endgroup$ – S.K. Oct 3 at 12:06
3
$\begingroup$

Your material blend mode is set to alpha blend, changing it to opaque fixes the issue.

enter image description here

enter image description here

$\endgroup$
  • $\begingroup$ I don't have that option in my material settings. Would it be because I'm in Cycles? imgur.com/a/EPkzZXh $\endgroup$ – S.K. Oct 4 at 4:33
  • 1
    $\begingroup$ Look dev uses eevee settings, switch to eevee, to change the setting then switch back to cycles. $\endgroup$ – Rc12 Oct 4 at 4:47
  • $\begingroup$ I hope that this paper-cut of the lookdev and cycle ui inconsistency will be resolved in the new blender updates. $\endgroup$ – softyoda yoann Oct 4 at 11:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.